两种方式解决 Gitlab 导入非标准端口项目报错


共计 653 个字符,预计需要花费 2 分钟才能阅读完成。

自建的 gitlab 迁移的时候,准备用导入项目的方式将项目迁移,但是在导入项目过程中遇到了如下错误:

Import url is blocked: Only allowed ports are 80, 443, and any over 1024

这个报错的意思是,只允许 80、443 和其他大于 1024 的端口,对于这个有两种方式解决。

  1. 方法1

首先找到 gitlab 的配置文件 url_blocker.rb。

如果你是 docker 运行,那么运行如下命令:

# 进入容器
docker exec -it gitlab bash

# 修改配置文件
vi /opt/gitlab/embedded/service/gitlab-rails/lib/gitlab/url_blocker.rb

然后搜索 1024,找到 return if port >= 1024 代码,修改为 return if port >= 0 ,保存然后重启。

# 重启
gitlab-ctl reconfigure && gitlab-ctl restart
  1. 方法2

同样是进入容器,编辑 url_blocker.rb 文件。

# 进入容器
docker exec -it gitlab bash

# 修改配置文件
vi /opt/gitlab/embedded/service/gitlab-rails/lib/gitlab/url_blocker.rb

找到如下代码:

def validate!(
        url,
        ports: [xx],
        ...
)

将自己的端口添加到 ports 数组即可,保存然后重启。

# 重启
gitlab-ctl reconfigure && gitlab-ctl restart

提醒:本文发布于398天前,文中所关联的信息可能已发生改变,请知悉!

Tips:清朝云网络工作室

1、本网站名称 清朝云资源网
2、本站永久连接https://www.qcyqq.com/7908.html
3、本网站的文章部分内容可能来源于网络,仅供大家学习与参考,如有侵权,请联系站长进行删除处理。
4、本站一切资源不代表本站立场,并不代表本站赞同其观点和对其真实性负责。
5、本站一律禁止以任何方式发布或转载任何违法的相关信息,访客发现请向站长举报
6、本站资源大多存储在云盘,如发现链接失效,请联系我们我们会第一时间更新。
7.站长联系方式:766378891@qq.com
THE END
分享
二维码
海报
两种方式解决 Gitlab 导入非标准端口项目报错
共计 653 个字符,预计需要花费 2 分钟才能阅读完成。 ……
<<上一篇


百度热搜新闻


新闻来源:百度热搜榜

1.)">
下一篇>>